Thursday, June 2, 2011

Error when running the migrationUtil to upgrade to OAM

In one of my test VMs I have IAM 11g R1 installed and am upgrading to Patch Set 1 (PS1), also known as In the upgrade process (which I'll be blogging about later) I ran into a problem running migration util.

When you run the migration utility it exports all of the objects in your OAM store to a compressed and encrypted file. The tool, run from the command line, connects to the WebLogic Server and iterates through all of the objects. I've been using this environment for a while and have added and deleted authentication schemes, user directories and basically every other object possible. In doing so I managed to get the environment into a perfectly operable state which the migration utility doesn't like.

On the migration utility site I see this stack trace:

Jun 1, 2011 6:17:44 PM read_value
WARNING: "IOP00810257: (MARSHAL) Could not find class"
org.omg.CORBA.MARSHAL:   vmcid: SUN  minor code: 257 completed: Maybe

Which isn't particularly helpful. On the WebLogic Server side I got this error which IS helpful:

<Jun 1, 2011 6:17:44 PM EDT> <Error> <oracle.oam.t2p> <OAM-22023> <Error while setting the default authentication scheme: {0}
        at Source)
        at Source)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(
Which, as you would expect, means that none of the Authentication Schemes are marked as the default scheme. To fix the problem you need only open up the OAM Console, navigate to the LDAPscheme Authentication Schemes and click the "set as default" button.

1 comment:

  1. Perfect this was the exact problem I was having and it fixed it.


Note: Only a member of this blog may post a comment.